Contributors mailing list archives

contributors@odoo-community.org

Avatar

Re: Add module version numbers guideline

by
Tecnativa. S. L., Pedro M. Baeza
- 06/08/2015 07:45:11
I agree with this rationale, as said on the PR.

Regards.

2015-08-06 9:38 GMT+02:00 Daniel Reis <dgreis@sapo.pt>:

Hello all,


There is a proposal to add a guideline for module version numbers for OCA contributions.
Is a nutshell, after some discussion the current proposal is to use 5 version numbers, for example: "8.0.1.0.0".
The two first numbers ones for the Odoo target version.: "8.0".
The next three ones for the module 's semantic version "x.y.z" ("breaking.feature.fix").

Rationale:

«It is unfortunate that most modules don't include in the manifest the information of the major Odoo version they target. This is an important information since most of the time modules are incompatible with other Odoo version other than the one they target.
For example: it is frequent to find code in GitHub with an Odoo module in a "master" branch, but can't be sure of what Odoo version it targets by looking at it's manifest file.

This is so because in the past Odoo/Openerp automatically added the major version to module versions. Thus if your module was version "6.1.1", it would be displayed as "6.1.6.1.1".

It is no longer the case: now Odoo does not do that if the major version is already appended to the module version!

Thus the Odoo target version can be included in the module version without being duplicated by the loading functions, and properly document the module's Odoo target version.»


Please join the discussion on the GitHub Pull Request and leave your comments there:
https://github.com/OCA/maintainer-tools/pull/100


Thank you
Daniel Reis

_______________________________________________
Mailing-List: http://odoo-community.org/groups/oca-contributors-15
Post to: mailto:contributors@odoo-community.org
Unsubscribe: http://odoo-community.org/groups?unsubscribe


Reference