Contributors mailing list archives

contributors@odoo-community.org

Re: odoo 10 does not find any tests

by
antiflu
- 28/11/2017 11:09:25
It will also fail silently when the module is not installed in your db currently

Op 28 nov. 2017 12:02 schreef "Ronald Portier" <ronald@therp.nl>:
Hi Robert,

Two more things to check:
--log-level=test

And has your module demo data loaded? Actually wether there is any demo
data or not is not important (unless your tests depend on that data).
You can just set demo = true in ir_module_module table through sql.

Kind regards,

Ronald


On 28-11-17 09:32, robert wrote:
> Hi there,
> 
> 
> I try to add test to a module and do call them like this:
> 
> bin/start_openerp  --test-enable -u redhelpdesk --stop-after-init
> 
> the file with the tests is loaded, but none of the tests are run.
> 
> can anybody give me a hint, what I am doing wrong?
> thanks
> Robert
> 
> 
> this is the setting:
> 
> redhelpdesk
>      ...
>      tests
>          __init__.py
> 
>              from . import test_redhelpdesk
> 
>      test_redhelpdesk.py
> 	with the following content:
> 
> # -*- encoding: utf-8 -*-
> from odoo.tests.common import TransactionCase
> 
> class TestRedhelpdesk(TransactionCase):
> 
>      def setUp(self, *args, **kwargs):
>          super(TestRedhelpdesk, self).setUp(*args, **kwargs)
>          print 'holla*' * 10
> 
>      def test_print_rs(self):
>          "print a string of rs"
>          print 'r' * 66
>          self.assertFalse(1, '1 is not false')
> 
> 
> 
> 	
> 
> _______________________________________________
> Mailing-List: https://odoo-community.org/groups/contributors-15
> Post to: mailto:contributors@odoo-community.org
> Unsubscribe: https://odoo-community.org/groups?unsubscribe
> 


_______________________________________________
Mailing-List: https://odoo-community.org/groups/contributors-15
Post to: mailto:contributors@odoo-community.org
Unsubscribe: https://odoo-community.org/groups?unsubscribe