Contributors mailing list archives

contributors@odoo-community.org

Re: Contract without analytic

by
Dave Lasley
- 10/07/2017 20:56:12
Is there a need for the business part? What about just `agreement`?

I also think maybe we should name the base module with the prefix base_ instead of account. The goal of this was to totally break away from the current account-style contracts, yeah?

Also, the core modules need to go first in the naming schema so my proposal is like:

base_agreement
account_agreement
sale_agreement
sale_stock_agreement


— Dave Lasley

On Jul 10, 2017, at 1:53 PM, Alexis de Lattre <alexis.delattre@akretion.com> wrote:

OK. So I'll propose a set of modules to OCA/contrat with names such as :
- business_agreement_account (will be the "base" module ; will depend on account)
- business_agreement_sale  (will depend on sale)
- business_agreement_sale_stock (only for v8, to copy info from sale.order to account.invoice when invoicing from picking)

I you prefer a different naming, please suggest an alternative.

Regards,

--
Alexis de Lattre

2017-07-10 13:53 GMT+02:00 Joël Grand-Guillaume <joel.grandguillaume@camptocamp.com>:
+1 for using *_agreement and purpose it under the OCA/contract repo