Contributors mailing list archives

contributors@odoo-community.org

Avatar

Re: New repos proposal

by
Sunflower IT, Tom Blauwendraat
- 16/06/2022 09:35:06



On 6/16/22 10:22, Daniel Reis wrote:

Adding multiple repos makes it harder for contributors to know where to submit a new module.

Can we make sure there are clear scope statements in the READMEs, and that these also link to the closely related ropes, helping contributors know about them.
Agree with this totally.

To make these scope statements more concrete:

1. web-api : collect modules to expose or deal with web api (eg: custom management for routes and endpoints, generic tools to handle calls to ext api, etc).
This description as a scope statement IMO should be better, it should be crystal clear why this is not part of "OCA/rest-framework". As it stands now, this text does not teach or convince me why it should be separate. Could we come up with a better text?

2. pwa-builder : collect modules that allow to create and manage standalone PWA apps. As many of you know I split the core of the shopfloor wms app some time ago and this core now allows you to create - potentially - any kind of PWA app w/ its backend (based on rest services) and frontend tools (VueJS based). This core is now in OCA/wms but that's not really the right place. The name is not adequate too (shopfloor_base) so I think I'm going to rename it to pwa_core or pwa_builder or something similar.

For this the reason to separate is much more clear. OCA/wms is definitely the wrong place, as you want to be able to use this framework for "any app".

Three questions though:

1. Why "builder" ? Does this actually build apps for you, or is it just a framework. A builder sounds to me as a tool that allows you to generate an app from building blocks. If a framework, "pwa", "pwa-core", "pwa-engine" or "pwa-framework" sounds more appropriate to me.

2. Is this limited to be used as a PWA, or can it also just be used as a replacement for the Odoo web portal? In my view, a "PWA" is something that has a service worker and can be "installed" to your system. Otherwise something like "web-app-engine" would be more appropriate (analogous to reporting-engine: housing an alternative OCA reporting engine)

3. Considering that it's based on VueJS, wouldn't a better name be "web-app-vuejs" or "pwa-vuejs", in order to separate it from efforts by any future OCA member companies who prefer Angular or React as their tool of choice, and want to open source their alternative engine?



Reference