Contributors mailing list archives

contributors@odoo-community.org

Avatar

Re: V14, python version

by
Tecnativa. S. L., Pedro M. Baeza
- 08/09/2021 13:13:40
It's current Debian stable python version.

Regards.

El mié., 8 sept. 2021 15:12, Tom Blauwendraat <tom@sunflowerweb.nl> escribió:

I think I read in another discussion that their philosophy was to support the Python version of the oldest, still supported Ubuntu LTS version. But I could be wrong.

On 9/8/21 3:02 PM, David Beal wrote:
Hi all,

What's your opinion here ?

Regards

David BEAL
Consultant ERP Odoo


Le mar. 8 déc. 2020 à 14:16, Raphaël Valyi <rvalyi@akretion.com> a écrit :
right on the spot David.

Now sadly I don't think we can expect any move from Odoo SA on this. IMHO they support old Python versions a bit by accident, because they come from legacy Python so by default they tend to have legacy Python compliant code while they make efforts to embrace new Python versions.

Even if it's not just by accident, Odoo SA follows a different logic: they maintain only 350 modules or so, they push new customers to new versions and push their paid migration. The ERP reality is not migrating every year nor even every 2 years on large projects. Take the LTS resonance (every 2 years so far) into account, and consider a company has any problem to migrate after 2 years only and now they probably wait 4 years and Odoo SA policy forces them to run unmaintained code with ERP features exposed on the web by packages exposed to security issues... Instead Odoo SA likes his ERP to be just one click away to install and test on any distro, even if (and may be especially if) it's not to run it for real and buy some comercial Odoo hosting with them or a partner later.

So I agree with you about how bad this is to support nearly end of life Python versions in the newest Odoo release where choice is available, but I think this is up to the OCA to educate the community, explain it that choosing libs done for nearly end of life Python is what will make their whole ERP obsolete with security exploits all exposed over the web in just 1 or 2 years. So I think the OCA should assume a different and more responsible policy than Odoo SA and require recent enough Python on recent Odoo versions (like what about 3.7 on v14, I mean at least a Python version with a life cycle compatible with the Odoo official one).

Regards.

On Tue, Dec 8, 2020 at 9:16 AM David Beal <david.beal@akretion.com> wrote:
Hi,

FYI another example of maintenance burden of multiple python versions

For the future, we probably need to be more persuasive to convince Odoo to only support recentest versions

It will impact OCA and your container projects.

Regards

David BEAL - akretion.com
Consultant
Odoo Intégration / Développement


Le lun. 19 oct. 2020 à 17:16, Juan José Scarafía (ADHOC) <scarafia.juanjose@gmail.com> a écrit :
Thanks Moi!
IMHO, we should go for python 3.8 on v14
Stay as we are on any previous version.

Ing. Juan José Scarafía

(+54 9 341) 3 278039

twitter: @jjscarafia

github: @jjscarafia



On Mon, Oct 19, 2020 at 12:06 PM Moises Lopez <moylop260@vauxoo.com> wrote:
> David, An example of ugly code to support python 3.7 or lower is here

So, this code must be applied for 3.6 too (I thought only 3.7)

> Stéphane, With that we can safely announce that OCA supports and tests 14.0 with py 3.6 and 3.8, and that 3.7 should work but we don't test it due to limited resources.

Then this sentence change a little bit.
Since that the ugly code is required for 3.6 too.

Fabien Meghazi from Odoo commented the following:

They are preparing to migrate Odoo v13.0 servers to py3.8 in OdooSH

So, py3.8 will be more stable than before.

I think it is because py3.6 will be obsolete in 1 year (2021-12)
In 1 year will be obsolete Odoo v12.0, so it won't require migrate to py3.8
And the latest stable version of python in Ubuntu LTS is 3.8 (3.7 was bypassed)

Should we work with patches to support python versions that will be obsolete in the short term or won't be used?

Even if we can enable 2 or more python versions in the CI, it will require extra code.

IMHO even if Odoo in this moment is supporting py3.6,
in the short term it is a waste of time and resources.
But I don't know I could be wrong.

What do you think after this?

_______________________________________________
Mailing-List: https://odoo-community.org/groups/contributors-15
Post to: mailto:contributors@odoo-community.org
Unsubscribe: https://odoo-community.org/groups?unsubscribe

_______________________________________________
Mailing-List: https://odoo-community.org/groups/contributors-15
Post to: mailto:contributors@odoo-community.org
Unsubscribe: https://odoo-community.org/groups?unsubscribe

_______________________________________________
Mailing-List: https://odoo-community.org/groups/contributors-15
Post to: mailto:contributors@odoo-community.org
Unsubscribe: https://odoo-community.org/groups?unsubscribe



--
Raphaël Valyi
Founder and consultant

_______________________________________________
Mailing-List: https://odoo-community.org/groups/contributors-15
Post to: mailto:contributors@odoo-community.org
Unsubscribe: https://odoo-community.org/groups?unsubscribe

_______________________________________________
Mailing-List: https://odoo-community.org/groups/contributors-15
Post to: mailto:contributors@odoo-community.org
Unsubscribe: https://odoo-community.org/groups?unsubscribe

_______________________________________________
Mailing-List: https://odoo-community.org/groups/contributors-15
Post to: mailto:contributors@odoo-community.org
Unsubscribe: https://odoo-community.org/groups?unsubscribe

Reference