Contributors mailing list archives
Re: New set of module "Requests".by
Ecosoft Co. Ltd., Kitti Upariphutthiphong
I am also thinking about "hr_request", "hr_request_???". Because I think it towards end users / employee use.
But says, we have hr_request_purchase_request, hr_request_stock_request, it might sound weird.
On Thu, Jul 29, 2021 at 2:42 PM Simone Orsi <email@example.com> wrote:
Hello there :)Can we avoid using "request" as name? As we are on a web app this clashes w/ the base concept of `request`.Any better specific name?CheersOn Thu, Jul 29, 2021 at 9:37 AM Pedro M. Baeza (Tecnativa) <firstname.lastname@example.org> wrote:OK, thanks for the explanation. I think we already have some of this as a specific thing (purchase_request, stock_request), and this can be a generalization, and they can maybe be derived from this one in the future.Please don't use plurals in module names though. Call it `request`.Regards.
--Simone OrsiFull stack Python web developer, Odoo specialist, Odoo Community Board Member, in love with open source.