Contributors mailing list archives

contributors@odoo-community.org

Avatar

Re: V14, python version

by
Akretion France, David BEAL
- 17/10/2020 12:37:50
Hi,

An example of ugly code to support python 3.7 or lower is here

Probably this code should go in many modules.

Thanks Moises for these informations

As said by Olivier Dony:

For Odoo.sh and SaaS deployment we generally use common sense: we run the version of Python that is shipped with the latest Ubuntu LTS at the time of the release, because that's what we deploy on. We expect it to be the most stable and the most widely run version for our users. For v13 that was Python 3.6, and for v14 that's Python 3.8

Common sense helps a lot in life generally speaking. All those which implement odoo projects should be advised to follow common sense I suppose.
OCA could help to spread the word of common sense.

Update python version in project is not so challenging (specifically at the beginning of the project) compared to having specific code in modules according to versions.

my 2 cts

Regards


David BEAL - akretion.com
Consultant
Odoo Intégration / Développement


Le sam. 17 oct. 2020 à 12:01, Stéphane Bidoul <stephane.bidoul@acsone.eu> a écrit :
Thanks for taking up the topic with Odoo SA Moises. In the reply from Olivier I quote: "But why should you care about this? For the OCA I can't imagine any other option than to support all the same Python versions that are supported by the matching Odoo version. Anything else would just cause issues for your users. Sorry about that ;-)"

So yeah, I still think testing on 3.6 is a must and testing one of the two jobs on 3.8 is the best we can reasonably do in the short term.


With that we can safely announce that OCA supports and tests 14.0 with py 3.6 and 3.8, and that 3.7 should work but we don't test it due to limited resources.

Does that sound reasonable?

-sbi


On Fri, Oct 16, 2020 at 9:13 PM Moises Lopez <moylop260@vauxoo.com> wrote:
Hello everyone,

I liked to know the Odoo internal opinion before to reply this thread.

Maybe you are interested of Olivier Dony answer too:

Summary:
 - Currently, runbot is running py3.6 for all current LTS versions (12.0, 13.0, 14.0)
 - They are in R&D to run py3.6, py3.7 and py3.8 in runbot for Odoo-14.0 builds
 - Odoo.sh is using py3.8 for 14.0 but py3.6 for 12.0 and 13.0

Checking the "Table of versions" (1)
 - py3.6 will be deprecated soon at 2021-12 (1y2mo)

py3.7 requires ugly code to support something basic as unittests like David commented us.

Python3.8 will be tested in runbot.odoo.com (someday R&D)
Python3.8 is used in live production in CD/CI Odoo.sh
It should ensure fixes over this version similar to (2)

So, the python version in the intersection is py3.8

If for OCA is too expensive to support py3.6, py3.7 & py3.8 for now
Then, Should we pinned the CI to py3.8?

What do you think?

Note: FYI in Vauxoo, we have decided to use py3.8
in live production (CD) and CI for Odoo v14.0 too

_______________________________________________
Mailing-List: https://odoo-community.org/groups/contributors-15
Post to: mailto:contributors@odoo-community.org
Unsubscribe: https://odoo-community.org/groups?unsubscribe

_______________________________________________
Mailing-List: https://odoo-community.org/groups/contributors-15
Post to: mailto:contributors@odoo-community.org
Unsubscribe: https://odoo-community.org/groups?unsubscribe

Reference