Contributors mailing list archives

contributors@odoo-community.org

Avatar

Re: V14, python version

by
Acsone SA/NV, Stéphane Bidoul
- 14/10/2020 08:41:55
I think OCA CI must run with the same python version as the oldest supported by Odoo.
If we test, say with python 3.8, people installing OCA modules on otherwise Odoo supported python versions may face compatibility issues.
In the other direction, compatibility issues will be much much less frequent, python being pretty good at ensuring backward compatibility.

Python 3.6 is supported until end 2021.

But we may want to clarify if what Odoo says in setup.py is correct. I don't know what python version Odoo uses on their runbot for instance.

-sbi


On Wed, Oct 14, 2020 at 10:07 AM David Beal <david.beal@akretion.com> wrote:
Ok I haven't seen that before, thanks.

The problem to begin with an old version is that even for recent projects, 12.0, you get bad signal only after 2 year.

DEPRECATION: Python 3.5 reached the end of its life on September 13th, 2020. Please upgrade your Python as Python 3.5 is no longer maintained. pip 21.0 will drop support for Python 3.5 in January 2021. pip 21.0 will remove support for this functionality.

I don't think it is a good thing for my customer to early have a deprecated python version.
I suppose that the better way to avoid it is to have a recent python version used on OCA CI and then in our project whatever Odoo SA python policy version.

Bonne journée


David BEAL - akretion.com
Consultant
Odoo Intégration / Développement


Le mer. 14 oct. 2020 à 09:42, Stéphane Bidoul <stephane.bidoul@acsone.eu> a écrit :
I've not looked into the cases you mentioned yet, but I note Odoo declares itself as supporting python 3.6:

That's why the OCA 14.0 branches have been created for python 3.6 too.

-sbi

On Wed, Oct 14, 2020 at 9:27 AM David Beal <david.beal@akretion.com> wrote:
Hi all,

The last very stable python is 3.8 (first version in November 2019), 3.8.6 in September 2020

Odoo 14.0 released in October supports python 3.7 and upper but that's not without consequence

We can ask ourself what is the benefit to support 3.7.

If yes, we have to deal with this kind of code in our OCA 14.0 module like here

Maybe there is a better way to manage this version incompatibility but if not
it can be difficult to ensure 3.7 compatibility in our modules

Without this compatibility code we have this kind of error

Are you really sure that supports 3.7 is good thing for our client in a fresh new project 14.0 while python 3.8 is very stable ?

Even in debian targeted version we may upgrade to 3.8

What do you think ?

Regards

David BEAL - akretion.com
Consultant
Odoo Intégration / Développement

_______________________________________________
Mailing-List: https://odoo-community.org/groups/contributors-15
Post to: mailto:contributors@odoo-community.org
Unsubscribe: https://odoo-community.org/groups?unsubscribe

_______________________________________________
Mailing-List: https://odoo-community.org/groups/contributors-15
Post to: mailto:contributors@odoo-community.org
Unsubscribe: https://odoo-community.org/groups?unsubscribe

_______________________________________________
Mailing-List: https://odoo-community.org/groups/contributors-15
Post to: mailto:contributors@odoo-community.org
Unsubscribe: https://odoo-community.org/groups?unsubscribe

Reference