Contributors mailing list archives

contributors@odoo-community.org

Avatar

Re: Travis CI fails

by
Camptocamp SA, Simone Orsi
- 21/07/2020 05:51:09
Hello Carlos,

in your build I see `mass_mailing_custom_unsubscribe` failing.

Anyway, when unrelated modules give errors it can be for several reasons [1].
If the base branch is green and only your build fails, you should try to understand why.

To understand why, try to run the tests for failing modules on your machine to try to replicate the problem.
If they work locally, then there's something weird on travis tests. If they fail, then try to fix them and possibly open another PR only for the fix(es).

[1] There might be conflicts in tests or demo data or a dependency got changed or an extra inheritance changed the behavior or a "flappy test" that fails randomly (maybe because of poor isolation)... a lot of possibilities.

If you don't find your path to the fix, you can ask for help here.

HTH,
S.


On Mon, Jul 20, 2020 at 11:06 PM Carlos Manuel Alvarez López <cmanuel.alvarez11@gmail.com> wrote:
Hello.
I am at a point where there are no code or style errors in my code, I have taken into account all the guidelines required by the OCA to perform the PR, since Travis CI does not find problems in my code, but nevertheless continues to fail due to errors related to other modules, for example website_mass_mailing_name, any recommendations


Best regards

_______________________________________________
Mailing-List: https://odoo-community.org/groups/contributors-15
Post to: mailto:contributors@odoo-community.org
Unsubscribe: https://odoo-community.org/groups?unsubscribe



--
Simone Orsi

Full stack Python web developer, Odoo specialist, Odoo Community Board Member, Freelance in love with open source.

Reference