France mailing list archives

france@odoo-community.org

Avatar

Re: Questions basiques

by
Quentin THEURET
- 30/06/2016 11:53:41
Le 28/06/2016 20:22, Mathieu BETTON a écrit :
> Bonjour à tout le monde
Bonjour Mathieu,
> J'inaugure ce que j'espère une foisonnante foire aux questions avec des
> questions basiques d'un nouveau venu sur odoo:
>
> Je ne comprends pas la gestion des modules et des thèmes
>
> Je voudrai installer des thèmes et des modules proposés par la
> communauté
> Mais je dois être neuneu parce que je ne trouve pas comment faire
>
> Le site de documentation de odoo indique, pour les thèmes:
> To install your theme, you just place your theme folder inside addons
> in your Odoo installation.
>
> mais je ne connais pas mon répertoire des thèmes !
> idem pour les modules
>
> j'ai bien cette ligne: addons_path = /usr/lib/python2.7/dist-
> packages/openerp/addons dans mon openerp-server.conf mais le répertoire
> est plein de sous-répertroires alors que mon installation est neuve
> Et il suffirait d'y décompresser l'archive téléchargée sur le net ?
Odoo est un framework/ERP modulaire, ce qui fait qu'il est composé d'une 
multitude de modules (d'où le fait d'avoir plein de sous-répertoires).

Il suffit donc de mettre le dossier contenant un fichier __openerp__.py 
dans le répertoire /usr/lib/python2.7/dist-packages/openerp/addons
> j'ai essayé avec un module et avec un thème, relancé odoo et aucune
> visibilité sur le module ou le thème installé.

Ensuite, lorsque le répertoire du module est en place, il faut aller 
dans Odoo et faire une mise à jour de la liste des modules.
Pour la v8, voir 
http://stackoverflow.com/questions/27124806/where-is-update-modules-list-in-odoo-v8
Pour la v9, je n'ai pas testé, mais je crois qu'il faut activer le mode 
« développeur » pour voir apparaître ce menu : 
http://pulse7.net/openerp/odoo-9-how-to-activate-developer-mode/

> Par ailleurs certains modules disponibles ne sont pas téléchargeables.
> Je prends l'exemple de email gateway
> https://www.odoo.com/apps/modules/9.0/fetchmail/
>
> il est gratuit mais on ne peut pas le télécharger. La seule option
> proposée est télécharger la version 9.0 community !
> et s'il est déjà intégré à la version 9.0 community, je ne le trouve
> pas.

Pour l'installer, il faut aller dans la liste des modules et supprimer 
toutes les conditions de recherche par défaut en haut à droite de 
l'écran. Normalement, tu devrais alors voir tous les modules disponibles.

> Bref j'ai l'impression d'être complètement à côté de la plaque et de
> louper un élément essentiel
Ce n'est pas grave, nous sommes là pour t'aider.

J'espère avoir répondu à tes questions.

Cordialement,

-- 
Quentin THEURET
https://twitter.com/qtheuret

Reference