Contributors mailing list archives

contributors@odoo-community.org

CI Builds now uses requirements from odoo repository

by
Vauxoo, Moisés López Calderón
- 12/07/2017 18:46:10
Before:
 - We had a custom requirements.txt from OCA/maintainer-quality-tools (MQT) repository.

Now:
 - We deleted the previous custom requirements.txt from MQT
 - We are using the original odoo's requirements.txt

PR:

New possible errors
The file (1) "requirements mqt vs odoo diff" has all information with the changes of requirements between MQT, 8.0 and 10.0
We have detected the following errors:
1. odoo 10.0 requirements (2) uses different packages versions and could be incompatible with code created for old version.
  - Example "mock==2.0" could be incompatible with code created for "mock==1.0.1"
2. odoo 10.0 deleted packages.
  - Example "unittest2"

Solutions
For both cases the fix is adds explicitly the package and version to requirements.txt root file of your project.

Please, check the (1) document to detect easiest a issue related with this case.

Thank you!


--
Moisés López Calderón
Vauxoo - OpenERP's Gold Partner
Mobile: (+521) 477-752-22-30
Office: (+52) 477-773-33-46
web: http://www.vauxoo.com
twitter: @vauxoo
           @moylop260