Contributors mailing list archives

contributors@odoo-community.org

Re: runbot is back

by
Camptocamp France SAS, Alexandre Fayolle
- 07/11/2016 16:33:07
On 07/11/2016 16:07, Moises Lopez wrote:
> For a fast test of runbot_travis2docker feature I use a dummy repository
> 
> https://github.com/vauxoo-dev/runbot_branch_remote_name_grp_feature2
> This one just install base module and allow a fast build to verify all
> settings.
> 
> We can test it with the same repository or maybe we can create a dummy
> repository for OCA
> 
> _______________________________________________
> Mailing-List: http://odoo-community.org/groups/contributors-15
> Post to: mailto:contributors@odoo-community.org
> Unsubscribe: http://odoo-community.org/groups?unsubscribe
> 

Good idea.

Here we go:

https://runbot.odoo-community.org/runbot/repo/232

First build failed silently :-(

docker ps is empty, and docker images too.


Here's what I did in the set up:

* apt-get install docker.io (from jessie backports)

$ docker --version
Docker version 1.6.2, build 7c8fca2

* The account running Odoo is a member of the docker group
* the project has no dependency

I noticed in the logs the following line:


openerp.addons.runbot_travis2docker.models.runbot_build: Dockerfile
without TESTS=1 env. Skipping builds [3271674]

Could this be related to the problem at hand?


-- 
Alexandre Fayolle
Chef de Projet
Tel : +33 4 58 48 20 30

Camptocamp France SAS
Savoie Technolac, BP 352
73377 Le Bourget du Lac Cedex
http://www.camptocamp.com