Contributors mailing list archives

contributors@odoo-community.org

Annoucing setuptools-odoo 1.0.0b7 - CAUTION breaking change

by
Acsone SA, Stéphane Bidoul
- 22/09/2016 09:04:54
Hi,

As discussed previously in [1] and [2], version 1.0.0b7 contains a backward incompatible change that was made necessary to enable future publishing of Odoo addons to pypi.

The new version is available on pypi right now.

Documentation is available at https://pypi.python.org/pypi/setuptools-odoo

In a nutshell, package names have changed from odoo-addon-<addon_name> to odoo<8|9>-addon-<addon_name>. This enables publishing addons for different odoo series at the same place.

To migrate:
  • update your --find-links references to https://wheelhouse.odoo-community.org/oca
  • update your install_require sections and requirements.txt and change odoo-addon-<addon_name> to odoo<8|9>-addon-<addon_name>
  • it is also recommended to remove any .eggs or *.egg-info directory in your editable sources
To enable to previous behavior, export SETUPTOOLS_ODOO_LEGACY_MODE=1.

This should be the last release before 1.0.0. Testers and feedback welcome.

If you are interested, I'll be at the OCA sprint in October and we can work on this topic (ie update travis script to use it instead of oca-dependencies.txt, push to pypi, support Odoo 10, etc).

Best regards,

Stéphane Bidoul | @SBidoul
Acsone sa/nv | http://acsone.eu/ | +32 2 888 3120