Contributors mailing list archives
Re: New repos proposalby
Hi,On Thu, Jun 16, 2022 at 11:37 AM Tom Blauwendraat <firstname.lastname@example.org> wrote:
To make these scope statements more concrete:This description as a scope statement IMO should be better, it should be crystal clear why this is not part of "OCA/rest-framework". As it stands now, this text does not teach or convince me why it should be separate. Could we come up with a better text?1. web-api : collect modules to expose or deal with web api (eg: custom management for routes and endpoints, generic tools to handle calls to ext api, etc).It's not about REST, it's about any kind of WEB related API that you might want to expose or call.Examples:* inbound - an endpoint to accept a file upload or to create a record* outbound - configuration of an external web service to call + reusable tools or api to make this happenIn any case, the text I wrote in my first email was not intended to be the readme of the repo, was just to have an idea ;)2. pwa-builder : collect modules that allow to create and manage standalone PWA apps. As many of you know I split the core of the shopfloor wms app some time ago and this core now allows you to create - potentially - any kind of PWA app w/ its backend (based on rest services) and frontend tools (VueJS based). This core is now in OCA/wms but that's not really the right place. The name is not adequate too (shopfloor_base) so I think I'm going to rename it to pwa_core or pwa_builder or something similar.
For this the reason to separate is much more clear. OCA/wms is definitely the wrong place, as you want to be able to use this framework for "any app".
Three questions though:
1. Why "builder" ? Does this actually build apps for you, or is it just a framework. A builder sounds to me as a tool that allows you to generate an app from building blocks. If a framework, "pwa", "pwa-core", "pwa-engine" or "pwa-framework" sounds more appropriate to me.To be honest I don't care that much about this name, I'm open for suggestions ;) "builder" sounded in line with "mis-builder" and generic enough to not require another repo for additional modules. I mean, if we call it pwa-core (which I like more) then I won't put any other module there which is not for the "core" and then we'll need a new one like pwa-contribs (or any similar name). I don't dislike this option.Hence, if everybody prefers `-framework` or another option, I can change its name. No problem.
2. Is this limited to be used as a PWA, or can it also just be used as a replacement for the Odoo web portal? In my view, a "PWA" is something that has a service worker and can be "installed" to your system. Otherwise something like "web-app-engine" would be more appropriate (analogous to reporting-engine: housing an alternative OCA reporting engine)Potentially you can build any kind of PWA on top of it. Up to you. The backend is separated from the front, see below.Keeping PWA in the name sounds a bit more in line with what you'll end up with: an installable app. If you use it also as a website is up to you but you don't need it for creating a website only.
3. Considering that it's based on VueJS, wouldn't a better name be "web-app-vuejs" or "pwa-vuejs", in order to separate it from efforts by any future OCA member companies who prefer Angular or React as their tool of choice, and want to open source their alternative engine?No, it's not for VueJS only. There's a backend part and a frontend part. Today the front is based on VueJS but if you want to rewrite the front w/ ReactJS, you could.The backend part - as far as possible - is conceived to provide configuration, routes and specific endpoints to retrieve core info for the app.Hope is more clear now :)Bests
--Simone OrsiFull stack Python web developer, Odoo specialist, Odoo Community Board Member, in love with open source.