Contributors mailing list archives

contributors@odoo-community.org

Avatar

Re: New set of module "Requests".

by
Ecosoft Co. Ltd., Kitti Upariphutthiphong
- 29/07/2021 07:44:43
I am also thinking about "hr_request", "hr_request_???". Because I think it towards end users / employee use.

But says, we have hr_request_purchase_request, hr_request_stock_request, it might sound weird.

On Thu, Jul 29, 2021 at 2:42 PM Simone Orsi <simahawk@gmail.com> wrote:
Hello there :)

Can we avoid using  "request" as name? As we are on a web app this clashes w/ the base concept of `request`.

Any better specific name?

Cheers

On Thu, Jul 29, 2021 at 9:37 AM Pedro M. Baeza (Tecnativa) <pedro.baeza@tecnativa.com> wrote:
OK, thanks for the explanation. I think we already have some of this as a specific thing (purchase_request, stock_request), and this can be a generalization, and they can maybe be derived from this one in the future.

Please don't use plurals in module names though. Call it `request`.

Regards.

_______________________________________________
Mailing-List: https://odoo-community.org/groups/contributors-15
Post to: mailto:contributors@odoo-community.org
Unsubscribe: https://odoo-community.org/groups?unsubscribe



--
Simone Orsi

Full stack Python web developer, Odoo specialist, Odoo Community Board Member, in love with open source.

_______________________________________________
Mailing-List: https://odoo-community.org/groups/contributors-15
Post to: mailto:contributors@odoo-community.org
Unsubscribe: https://odoo-community.org/groups?unsubscribe

Reference